博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
大菲波数
阅读量:6471 次
发布时间:2019-06-23

本文共 1006 字,大约阅读时间需要 3 分钟。

Problem Description 
 
Fibonacci数列,定义如下:f(1)=f(2)=1,f(n)=f(n-1)+f(n-2) n>=3;
计算第n项Fibonacci数值。
Input
输入第一行为一个整数N,接下来N行为整数m(1<=m<=1000)。
Output
输出为N行,每行为对应的f(m)。
Sample Input
3234
Sample Output
123
 
 

 

 

#include<iostream>

#include<list>
#include<string>
using namespace std;

list<int> BigAddList(list<int> La,list<int> Lb )
{
list<int> Lc;
list<int> ::iterator it1,it2;
it1=La.begin();
it2=Lb.begin();

int carry=0;

while(it1!=La.end()||it2!=Lb.end())
{
int c=carry;
if(it1!=La.end())
{
c=c+(*it1);
it1++;
}
if(it2!=Lb.end())
{
c=c+(*it2);
it2++;
}
carry=c/10;
Lc.push_back(c%10);
}
if(carry>0) Lc.push_back(carry);
Lc.reverse();
return Lc;
}

 

int main()

{
int o;
cin>>o;
for(int v=0;v<o;v++ )
{
list<int>La,Lb,Lc,Ld;
Lc.push_back(1);
La.push_back(1);
Lb.push_back(1);
int T;
cin>>T;
for(int j=3;j<=T;j++)
{
Lc=BigAddList(La,Lb);
La=Lb;
Lb=Lc;
Lb.reverse();

}

for(list<int>::iterator it=Lc.begin();it!=Lc.end();it++)

{
cout<<*it;
}
Lc.clear();
cout<<endl;
}
}

转载于:https://www.cnblogs.com/ilovetheworld/p/10573162.html

你可能感兴趣的文章
利用react-redux-tpl快速开发react-redux-webpack项目
查看>>
Linux_《Linux命令行与shell脚本编程大全》第一章学习总结
查看>>
CI/CD:DevOps背后的推动力
查看>>
css布局:块级元素垂直居中
查看>>
深入JVM彻底剖析ygc越来越慢的原因(下)
查看>>
小米松果电子拆分成立大鱼半导体,专注IoT芯片研发
查看>>
架构之重构的12条军规(上)
查看>>
<转载>如何创建属于你自己的域名邮箱
查看>>
Java 虚拟机经典六问
查看>>
华中科大提出EAT-NAS方法:提升大规模神经模型搜索速度
查看>>
Entity Framework中的字符串插值引发担忧
查看>>
厚积薄发,看腾讯云如何快速从IPv4向IPv6演进?
查看>>
Eclipse基金会发布Eclipse Photon IDE
查看>>
国内移动测试服务盘点
查看>>
系统监控:top vs Htop vs Glances
查看>>
Ktor 1.0发布:JetBrains推出的Kotlin Web框架
查看>>
Apple计划开发完全定制的GPU架构
查看>>
送给 Java 程序员的 Spring 学习指南\n
查看>>
Kafka多数据中心部署灾备三要素
查看>>
laravel 如何添加自定义帮助函数
查看>>